Acquirer Service Interruption - PostFinance

Incident Report for 934 Ltd

Resolved

This incident has been resolved.
Posted Jul 14, 2026 - 15:37 UTC

Identified

The following services are currently partially or fully affected by a disruption: EFT/POS & E-Commerce Services with Acquiring PostFinance

Start of disruption: 14.07.2026 09:40 End of disruption: pending

The cause of the disruption is being investigated, and the Partner is doing everything they can to find a solution.

We apologize for the inconvenience.
Posted Jul 14, 2026 - 09:27 UTC
This incident affected: Juno Credit Card Terminals (PAX).