Missing Transactions in the Portal

Incident Report for 934 Ltd

Resolved

This incident has been resolved.
Posted Apr 07, 2026 - 17:50 UTC

Identified

We have identified an issue where some transactions are not appearing in the portal. Our team is actively working on resolving this as soon as possible. Further updates will be provided as soon as possible.
Posted Mar 24, 2026 - 09:49 UTC
This incident affected: Dashboard.