Token issue

Incident Report for 934 Ltd

Resolved

We would like to inform you that the issue has been resolved. We apologize for any inconvenience caused and thank you for your understanding.
Posted Apr 15, 2026 - 08:21 UTC

Investigating

Some customers are experiencing ‘invalid token’ errors during transactions. Our team is actively investigating this and will provide updates as more information becomes available.
Posted Apr 15, 2026 - 07:59 UTC
This incident affected: Juno Core.