Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 20, 2025 - 04:20 UTC
Update
We anticipate that the potential service interruption will be significantly shorter than the full 2-hour window within the maintenance window provided above. We are targeting a downtime of approximately 20 minutes to complete the upgrade and conduct thorough testing. During this brief period, commencing around 04:20 UTC, all transaction processing and other production services will be temporarily unavailable. This means that all API endpoints, as well as the Merchant and Admin web interfaces, will return maintenance notifications and will return an error. We are committed to bringing all services back online as quickly as possible following the upgrade.
Posted May 13, 2025 - 10:47 UTC
Scheduled
Maintenance Window: Maintenance Start Time (with timezone): 2025-05-20 04:00 UTC Maintenance End Time (with timezone): 2025-05-20 06:00 UTC Downtime: Start Downtime (with timezone): 2025-05-20 04:20 UTC End Downtime (with timezone): 2025-05-20 04:40 UTC