Acquirer Service Interruption

Incident Report for 934 Ltd

Resolved

This incident has been resolved.
Posted Jul 15, 2026 - 12:05 UTC

Identified

We would like to inform you about an ongoing technical issue impacting Mastercard 3-D Secure authentication as from Today, (15/07/2026) at 09:01 CEST .

This issue results in a number of transactions receiving a status 0 (Incomplete/invalid) or status 2 (Authorisation declined) due to the impossibility of performing a 3-D Secure check.

A dedicated team has been deployed to investigate the situation as a matter of urgency. An update will be provided shortly.

We also confirm that the issue has an external responsibility
Posted Jul 15, 2026 - 09:02 UTC
This incident affected: Juno Credit Card Terminals (PAX).