We are pleased to inform you that the services of our SIM Provider are now fully available again.
A hardware failure within their IP switching platform caused a brief disruption in the data connection for some SIM cards.
Start: ~ 10:21 AM CEST End: ~ 10:57 AM CEST
Your devices should be able to re-establish a data connection on their own again. If this does not work, you should restart the device. We apologize for any inconvenience this may have caused and thank you for your understanding.
Posted Sep 10, 2026 - 10:46 UTC
Identified
We are sorry to inform you that our SIM Provider is experiencing network issues with their data+ SIM cards.
Details of the interruption:Data traffic is affected
Start time: 11:06
We are working with our partners to find and rectify the problem as a matter of top priority. We will inform you as soon as the data connection is available again without disruption.
Posted Sep 10, 2026 - 09:35 UTC
This incident affected: Juno Credit Card Terminals (PAX).