Dashboard degradation

Incident Report for 934 Ltd

Resolved

This incident has been resolved
Posted Jun 20, 2025 - 11:44 UTC

Update

The team has identified the root cause and is working on a solution
Posted Jun 12, 2025 - 13:56 UTC

Identified

Some customers currently experiencing a delay in transaction data appearing in the Reporting Dashboard.
Posted Jun 12, 2025 - 13:55 UTC
This incident affected: Dashboard.