Elevated Failure rate for NEXI Acquiring

Incident Report for 934 Ltd

Resolved

This incident has been resolved.
Posted May 21, 2026 - 14:52 UTC

Identified

Our partner sees an elevated Failure rate for NEXI Acquiring. The Acquirer is working with high pressure to restore the service.
Posted May 21, 2026 - 08:23 UTC
This incident affected: Juno Credit Card Terminals (PAX).