Mobile Data service Interruption

Incident Report for 934 Ltd

Resolved

This incident has been resolved.
Posted Apr 07, 2026 - 17:51 UTC

Identified

We are sorry to inform you that Mobile data is temporarily unavailable in some regions due to Technical Issues by Providers.

We apologize for any inconvenience this may cause and appreciate your understanding as our partner work to resolve the issue as quickly as possible. We will keep you informed and provide an update soon. Thank you for your patience.

Please connect using WiFi as a workaround
Posted Apr 02, 2026 - 12:10 UTC
This incident affected: Juno Credit Card Terminals (PAX).